CVE-2026-6471
PostgreSQL logical decoding can dlopen arbitrary file
No known exploitation. EPSS puts it in the 44th percentile. Fixed versions are out.
What to do
Find your product and version, then upgrade to the build on the right.
- n/a PostgreSQLAffected: ≥ 18, < 18.6Upgrade to: 18.6Affected: ≥ 17, < 17.11Upgrade to: 17.11Affected: ≥ 16, < 16.15Upgrade to: 16.15Affected: ≥ 15, < 15.19Upgrade to: 15.19 + 1 more branchStated by: CVE record
- PostgresqlAffected: ≥ 14.0, < 14.24Upgrade to: 14.24Stated by: NVD
Versions as the sources state them. Full version matrix after sign-in
Coverage timeline
2 publishersPostgreSQL fixed a 12-year-old logical decoding flaw (CVE-2026-6471) detailed in a Cyera research write-up, which allowed replication users to execute arbitrary code.
Sourced from public security reporting — each date is when it was published, not when it happened. 1 further article named this CVE in wider roundups without reporting it as a distinct event.
What it is
From the CVE record
Missing authorization in PostgreSQL logical decoding allows a non-superuser holding REPLICATION privilege to dlopen any file visible to the operating system account running the server, via the choice of logical decoding plugin. This in turn runs arbitrary code as that account. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
In plain language
No plain-language summary for this CVE yet.
Exploitation
Where each signal puts this CVE on the scale from published to confirmed exploited.
- CISA KEV
Not in the catalog. CISA has not confirmed exploitation.
- Public exploits
No public exploit or proof of concept found in the sources we track.
- EPSS
0.5% chance of exploitation activity in the next 30 days, which ranks it in the 44th percentile of scored CVEs.
Exploit Prediction Scoring System, FIRST.org. A probability, not a confirmation.
Lifecycle
12 events over 16 days, from the signal feeds we watch.
- Patch availablerecord updated
- Patch availablerecord updated
- Record updated
- OpenVAS check added
- Record updated
- Publishedweakness classified, att&ck mapped, record updated, record updated
Affected products
And 1 more affected product. See all after sign-in
Technical detail
CVSS 3.1 vector
Open in the CVSS calculatorCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Scored 7.2 by NVD.
How it is reached
- Attack Vector NetworkExploitable remotely over the network without any special conditions
- Attack Complexity LowNo special conditions — the attack can be reliably reproduced
- Privileges Required HighRequires admin or elevated privileges
- User Interaction NoneNo user interaction needed — fully automated exploitation
Scope
- Scope UnchangedImpact is limited to the vulnerable component itself
Impact if exploited
- Confidentiality HighTotal information disclosure — all data in the component is compromised
- Integrity HighTotal loss of integrity — attacker can modify any data in the component
- Availability HighTotal denial of service — the component is completely unavailable
Weaknesses
ATT&CK techniques
Mapped from the weaknesses above (CWE to ATT&CK), not observed in attacks.
Sources
References in the record
In the news
Watch the software you run.
My Stack ranks new CVEs for your products by real-world exploitation, so the next serious one reaches you without reading every advisory.
We'll flag the next CVE, public exploit or patch for PostgreSQL, not every advisory.
A free account adds
- The full version matrix and every affected product
- Exploit links, proofs of concept and Metasploit modules
- Email alerts for the products you watch
- The same data over REST API, MCP and CLI