CVE-2026-112816
Improper certificate validation in the HTTPS listener in LXD
No known exploitation. EPSS puts it in the 23rd percentile. Fixed versions are out.
No public exploit knownFix1 product4 fixed builds listed below
No ready-made check. Neither Nuclei nor OpenVAS has one for this CVE yet.
What to do
Find your product and version, then upgrade to the build on the right.
- Canonical LXDAffected: ≥ 4.0.14, < 4.0.15Upgrade to: 4.0.15Affected: ≥ 5.0.10, < 5.0.11Upgrade to: 5.0.11Affected: ≥ 5.21.8, < 5.21.9Upgrade to: 5.21.9Affected: ≥ 6.9.0, < 6.10.1Upgrade to: 6.10.1Stated by: CVE record
Versions as the sources state them. Full version matrix after sign-in
Steps
Written by AI from the record- Check which LXD version your team is running (
lxc versionor ask your admin). - If running 4.0.14, 5.0.10, 5.21.8, 6.9, or earlier in those branches, plan an upgrade.
- Upgrade to the fixed version for your branch: 4.0.15, 5.0.11, 5.21.9, or 6.10.1.
- After upgrading, confirm the HTTPS listener is working normally and trusted clients can still authenticate.
What it is
From the CVE record
Improper certificate validation in the HTTPS listener in Canonical LXD 4.0.14, 5.0.10, 5.21.8, 6.9 before 4.0.15, 5.0.11, 5.21.9, 6.10.1 allows an unauthenticated attacker to authenticate as any trusted client and gain full access to the cluster and managed virtual machines via a crafted certificate chain.
In plain language
Written by AI from the recordA flaw in LXD's HTTPS listener could let someone impersonate a trusted client using a fake certificate, but it hasn't been seen exploited and there's a free fix available (upgrade to 4.0.15, 5.0.11, 5.21.9, or 6.10.1) so this is a routine patch, not an emergency.
Improper certificate chain validation in LXD's HTTPS listener (CWE-295) allows an unauthenticated attacker with a crafted certificate chain to be authenticated as any already-trusted client, gaining full cluster and VM access.
If you're affected
- Full cluster takeover
- Unauthorized VM access
- Data exposure on hosted VMs
- Operational disruption
Exploitation
Where each signal puts this CVE on the scale from published to confirmed exploited.
- CISA KEV
Not in the catalog. CISA has not confirmed exploitation.
- Public exploits
No public exploit or proof of concept found in the sources we track.
- EPSS
0.3% chance of exploitation activity in the next 30 days, which ranks it in the 23rd percentile of scored CVEs.
Exploit Prediction Scoring System, FIRST.org. A probability, not a confirmation.
Lifecycle
5 events over 1 day, from the signal feeds we watch.
- Record updated
- Publishedweakness classified, att&ck mapped, record updated
Affected products
Technical detail
Weaknesses
ATT&CK techniques
Mapped from the weaknesses above (CWE to ATT&CK), not observed in attacks.
Sources
References in the record
- github.com/canonical/lxd/security/advisories/GHSA-99jp-jwmc-65p4
- discourse.ubuntu.com/t/security-advisory-critical-vulnerability-found-in-canonical-lxd-and-microcloud/90557
- discourse.ubuntu.com/t/lxd-6-10-1-lts-has-been-released/90024
And 3 more references. See all after sign-in
In the news
Watch the software you run.
My Stack ranks new CVEs for your products by real-world exploitation, so the next serious one reaches you without reading every advisory.
We'll flag the next CVE, public exploit or patch for LXD, not every advisory.
A free account adds
- The full version matrix and every affected product
- Exploit links, proofs of concept and Metasploit modules
- Email alerts for the products you watch
- The same data over REST API, MCP and CLI