CVE-2021-23368
Regular Expression Denial of Service (ReDoS)
No known exploitation. EPSS puts it in the 89th percentile. Fixed versions are out.
No public exploit knownFix4 products3 fixed builds listed below
e.g. OID 1.3.6.1.4.1.25623.1.0.117733
What to do
Find your product and version, then upgrade to the build on the right.
- N/a PostcssAffected: ≥ 7.0.0, < unspecifiedUpgrade to: unspecifiedAffected: ≥ unspecified, < 8.2.10Upgrade to: 8.2.10Stated by: CVE record
- Npm PostcssAffected: ≥ 7.0.0, < 7.0.36Upgrade to: 7.0.36Stated by: GitHub advisory
- PostcssAffected: ≥ 7.0.0, < 7.0.36Upgrade to: 7.0.36Stated by: NVD
- ООО "Открытая мобильная платформа" Аврора ЦентрAffected: от 2.1.3 до 2.5.0 включительноUpgrade to: not statedStated by: BDU
Versions as the sources state them. Full version matrix after sign-in
What it is
From the CVE record
The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.
In plain language
No plain-language summary for this CVE yet.
Exploitation
Where each signal puts this CVE on the scale from published to confirmed exploited.
- CISA KEV
Not in the catalog. CISA has not confirmed exploitation.
- Public exploits
No public exploit or proof of concept found in the sources we track.
- EPSS
3.5% chance of exploitation activity in the next 30 days, which ranks it in the 89th percentile of scored CVEs.
Exploit Prediction Scoring System, FIRST.org. A probability, not a confirmation.
Lifecycle
5 events over 1900 days, from the signal feeds we watch.
- OpenVAS check added
- Patch availablerecord updated
- Publishedweakness classified
Affected products
Technical detail
CVSS 3.1 vector
Open in the CVSS calculatorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Scored 5.3 by NVD.
How it is reached
- Attack Vector NetworkExploitable remotely over the network without any special conditions
- Attack Complexity LowNo special conditions — the attack can be reliably reproduced
- Privileges Required NoneNo authentication required — anyone can exploit this
- User Interaction NoneNo user interaction needed — fully automated exploitation
Scope
- Scope UnchangedImpact is limited to the vulnerable component itself
Impact if exploited
- Confidentiality NoneNo confidentiality impact
- Integrity NoneNo integrity impact
- Availability LowReduced performance or intermittent disruption of service
Weaknesses
Sources
References in the record
- github.com/postcss/postcss/commit/8682b1e4e328432ba692bed52326e84439cec9e4
- github.com/postcss/postcss/commit/b6f3e4d5a8d7504d553267f80384373af3a3dec5
- lists.apache.org/thread.html/r00158f5d770d75d0655c5eef1bdbc6150531606c8f8bcb778f0627be%40%3Cdev.myfaces.apache.org%3E
And 16 more references. See all after sign-in
Watch the software you run.
My Stack ranks new CVEs for your products by real-world exploitation, so the next serious one reaches you without reading every advisory.
We'll flag the next CVE, public exploit or patch for Postcss, not every advisory.
A free account adds
- The full version matrix and every affected product
- Exploit links, proofs of concept and Metasploit modules
- Email alerts for the products you watch
- The same data over REST API, MCP and CLI