CVE-2018-5052
Exploitation likely. EPSS gives it a 11% chance of exploitation in the next 30 days. A vendor fix is available.
What to do
The vendor has published a fix. Version details are below where the sources state them.
- n/a Adobe Acrobat and Reader 2018.011.20040 and earlier, 2017.011.30080 and earlier, and 2015.006.30418 and earlier versionsAffected: Adobe Acrobat and Reader 2018.011.20040 and earlier, 2017.011.30080 and…Upgrade to: not statedStated by: CVE record
- Adobe Acrobat DcAffected: ≥ 15.006.30060, ≤ 15.006.30418Upgrade to: after 15.006.30418Stated by: NVD
Versions as the sources state them. Full version matrix after sign-in
Steps
Written by AI from the record- Check which Adobe Acrobat/Reader build you are running (Help → About) and confirm whether it is 2018.011.20040 or earlier, 2017.011.30080 or earlier, or 2015.006.30418 or earlier.
- If you are on an affected version, install Adobe’s remediation update from APSB18-21 (the fix described for CVE-2018-5052) and restart Acrobat/Reader.
- If you cannot update immediately, restrict exposure by preventing users from opening unknown or unsolicited files from email and the web (especially PDFs), and consider blocking risky attachment types until patching is complete.
- After updating, re-check the application version in Help → About to ensure the update actually took effect.
What it is
From the CVE record
Adobe Acrobat and Reader 2018.011.20040 and earlier, 2017.011.30080 and earlier, and 2015.006.30418 and earlier versions have a Heap Overflow vulnerability. Successful exploitation could lead to arbitrary code execution in the context of the current user.
In plain language
Written by AI from the recordCVE-2018-5052 is a memory-safety bug in older Adobe Acrobat/Reader versions that could let an attacker run code when you open a specially prepared file—small businesses should patch if they’re using those older versions.
CVE-2018-5052 is a heap overflow vulnerability in Adobe Acrobat and Reader (and adobe acrobat dc) versions 2018.011.20040 and earlier, 2017.011.30080 and earlier, and 2015.006.30418 and earlier; a crafted input can trigger memory corruption leading to potential arbitrary code execution in the current user context, typically requiring user interaction (e.g., opening a malicious file).
If you're affected
- Malware execution on user’s device
- Account takeover and data theft risk
- Possible ransomware entry point
- Operational disruption from compromise
Exploitation
Where each signal puts this CVE on the scale from published to confirmed exploited.
- CISA KEV
Not in the catalog. CISA has not confirmed exploitation.
- Public exploits
No public exploit or proof of concept found in the sources we track.
- EPSS
11% chance of exploitation activity in the next 30 days, which ranks it in the 96th percentile of scored CVEs.
Exploit Prediction Scoring System, FIRST.org. A probability, not a confirmation.
Lifecycle
22 events over 2987 days, from the signal feeds we watch.
- EPSS band changelow → moderateepss band change
- EPSS band changemoderate → lowepss band change
- EPSS band change0 → moderateepss band change
- EPSS band changemoderate → 0epss band change
- EPSS band change0 → moderateepss band change
- EPSS band changemoderate → 0epss band change
Affected products
And 2 more affected products. See all after sign-in
Technical detail
CVSS 3.0 vector
Open in the CVSS calculatorCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Scored 8.8 by NVD.
How it is reached
- Attack Vector NetworkExploitable remotely over the network without any special conditions
- Attack Complexity LowNo special conditions — the attack can be reliably reproduced
- Privileges Required NoneNo authentication required — anyone can exploit this
- User Interaction RequiredA user must click a link, open a file, or perform some action
Scope
- Scope UnchangedImpact is limited to the vulnerable component itself
Impact if exploited
- Confidentiality HighTotal information disclosure — all data in the component is compromised
- Integrity HighTotal loss of integrity — attacker can modify any data in the component
- Availability HighTotal denial of service — the component is completely unavailable
Weaknesses
ATT&CK techniques
Mapped from the weaknesses above (CWE to ATT&CK), not observed in attacks.
- Initial AccessT1190Exploit Public-Facing Applicationhigh confidence
- Privilege EscalationT1068Exploitation for Privilege Escalationhigh confidence
Sources
References in the record
Watch the software you run.
My Stack ranks new CVEs for your products by real-world exploitation, so the next serious one reaches you without reading every advisory.
We'll flag the next CVE, public exploit or patch for Acrobat Reader Dc, not every advisory.
A free account adds
- The full version matrix and every affected product
- Exploit links, proofs of concept and Metasploit modules
- Email alerts for the products you watch
- The same data over REST API, MCP and CLI