CVE Tools

CVE-2026-8168

Denial-of-service vulnerability in the SVG parser and renderer impacts Qt

No known exploitation. EPSS puts it in the 34th percentile. Fixed versions are out.

Published Updated Sources: CVE.org, NVD

What to do

Find your product and version, then upgrade to the build on the right.

  • QtAffected: ≥ 4.1.0, < 6.8.9Upgrade to: 6.8.9Affected: ≥ 6.9.0, < 6.11.2Upgrade to: 6.11.2Stated by: CVE record

Versions as the sources state them. Full version matrix after sign-in

What it is

From the CVE record

Uncontrolled recursion in the SVG parser and renderer of the Qt SVG module (QtSvg) in Qt Group Qt allows attackers to cause a denial of service (application crash via stack exhaustion) via a crafted SVG file with deeply nested elements.

In plain language

No plain-language summary for this CVE yet.

Exploitation

Where each signal puts this CVE on the scale from published to confirmed exploited.

EPSS34th
CISA KEV

Not in the catalog. CISA has not confirmed exploitation.

Public exploits

No public exploit or proof of concept found in the sources we track.

EPSS

0.4% chance of exploitation activity in the next 30 days, which ranks it in the 34th percentile of scored CVEs.

Exploit Prediction Scoring System, FIRST.org. A probability, not a confirmation.

Lifecycle

5 events over 0 days, from the signal feeds we watch.

  1. Publishedweakness classified, att&ck mapped, record updated, record updated

Affected products

Technical detail

Weaknesses

ATT&CK techniques

Mapped from the weaknesses above (CWE to ATT&CK), not observed in attacks.

Sources

Watch the software you run.

My Stack ranks new CVEs for your products by real-world exploitation, so the next serious one reaches you without reading every advisory.

We'll flag the next CVE, public exploit or patch for Qt, not every advisory.