CVE-2026-18024
PostgreSQL ascii() function reads past end of buffer
No known exploitation. EPSS puts it in the 23rd percentile. Fixed versions are out.
What to do
Find your product and version, then upgrade to the build on the right.
- n/a PostgreSQLAffected: ≥ 18, < 18.6Upgrade to: 18.6Affected: ≥ 17, < 17.11Upgrade to: 17.11Affected: ≥ 16, < 16.15Upgrade to: 16.15Affected: ≥ 15, < 15.19Upgrade to: 15.19 + 1 more branchStated by: CVE record
- PostgresqlAffected: ≥ 14.0, < 14.24Upgrade to: 14.24Stated by: NVD
Versions as the sources state them. Full version matrix after sign-in
What it is
From the CVE record
Buffer over-read in PostgreSQL ascii() SQL function allows a user to disclose up to 3 bytes after the end of a specific allocation, via a crafted text value. This is the same class of defect that CVE-2026-2006 fixed, though this instance has less impact. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.
In plain language
No plain-language summary for this CVE yet.
Exploitation
Where each signal puts this CVE on the scale from published to confirmed exploited.
- CISA KEV
Not in the catalog. CISA has not confirmed exploitation.
- Public exploits
No public exploit or proof of concept found in the sources we track.
- EPSS
0.3% chance of exploitation activity in the next 30 days, which ranks it in the 23rd percentile of scored CVEs.
Exploit Prediction Scoring System, FIRST.org. A probability, not a confirmation.
Lifecycle
10 events over 16 days, from the signal feeds we watch.
- Patch availablerecord updated
- Patch availablerecord updated
- Record updated
- OpenVAS check added
- Publishedweakness classified, record updated, record updated
Affected products
And 1 more affected product. See all after sign-in
Technical detail
CVSS 3.1 vector
Open in the CVSS calculatorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Scored 4.3 by NVD.
How it is reached
- Attack Vector NetworkExploitable remotely over the network without any special conditions
- Attack Complexity LowNo special conditions — the attack can be reliably reproduced
- Privileges Required LowRequires basic user-level privileges
- User Interaction NoneNo user interaction needed — fully automated exploitation
Scope
- Scope UnchangedImpact is limited to the vulnerable component itself
Impact if exploited
- Confidentiality LowSome restricted information is disclosed, but limited in scope
- Integrity NoneNo integrity impact
- Availability NoneNo availability impact
Weaknesses
Sources
References in the record
Watch the software you run.
My Stack ranks new CVEs for your products by real-world exploitation, so the next serious one reaches you without reading every advisory.
We'll flag the next CVE, public exploit or patch for PostgreSQL, not every advisory.
A free account adds
- The full version matrix and every affected product
- Exploit links, proofs of concept and Metasploit modules
- Email alerts for the products you watch
- The same data over REST API, MCP and CLI