No fixed build or workaround is published yet. Limit exposure and watch for a patch.
ProductAffected versionsUpgrade toStated by
WordPress Foundation WordPressAffected: ≥ 4.7.0, ≤ 4.7.38Upgrade to: after 4.7.38Affected: ≥ 4.8.0, ≤ 4.8.33Upgrade to: after 4.8.33Affected: ≥ 4.9.0, ≤ 4.9.34Upgrade to: after 4.9.34Affected: ≥ 5.0.0, ≤ 5.0.30Upgrade to: after 5.0.30 + 21 more branchesStated by: CVE record
Sourced from public security reporting — each date is when it was published, not when it happened.
What it is
From the CVE record
WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.
In plain language
Written by AI from the record
This is a serious weakness in WordPress Core (versions 4.7 through 7.1.3) that attackers are already exploiting, and there is no fix available yet, so every WordPress site should treat this as urgent.
Unauthenticated remote code execution in WordPress Core 4.7–7.1.3 arising from predictable, web-accessible staging paths exposed during full-package core upgrades, allowing an attacker to drop and execute code on the server while an upgrade is in progress (CWE-367, race condition on a time-of-check/time-of-use file path).
If you're affected
Full server takeover
Website defacement
Customer data exposure
Malware or ransomware deployment
Site downtime
What is it
WordPress is the software that runs your website's back end. This flaw is like leaving a side door unlocked for a few minutes every time you perform a software update — during that brief window, anyone on the internet, without needing a password, can slip in and plant their own code on your server. If exploited, an attacker could take over your entire website.
Who is affected
This matters to you if your website runs WordPress Core, specifically any version from 4.7 through 7.1.3. No login or special access is needed for an attacker to exploit it — the risk exists any time your site goes through a core upgrade and is reachable from the internet.
How urgent is it
Attackers are already exploiting this vulnerability in the wild, and it is on CISA's confirmed exploited list with a remediation deadline of November 6, 2026 — just two days from now. There is no official patch available yet, which makes this a red-alert situation: you need to take protective action now rather than wait for a fix.
What to do — in detail
Inventory all WordPress installations and confirm whether any are running Core versions 4.7 through 7.1.3. 2. No vendor patch is currently published for this CVE — monitor WordPress.org security advisories and your hosting provider's bulletins closely for an emergency release. 3. Until a fix ships, minimize exposure: avoid triggering full-package core upgrades on internet-facing, unauthenticated-reachable instances, or perform upgrades only from an isolated/maintenance-mode environment with network access restricted during the upgrade window. 4. Deploy a WAF rule or reverse-proxy block that denies external requests to predictable staging/upgrade paths (e.g., wp-admin/upgrade temp directories) as a stopgap. 5. Per CISA KEV guidance (BOD 26-04), the remediation due date is 2026-11-06 — if no mitigation can be applied by then, evaluate discontinuing use of the affected instance per federal guidance, and document compliance regardless of sector. 6. Monitor web server and application logs for unexpected file writes or PHP execution in temp/upgrade directories, and for anomalous outbound connections post-upgrade. 7. Once a patched version is released, upgrade immediately and verify no backdoor files were planted during any prior upgrade cycle.
Technical context
CVSS 8.1 (AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H) reflects high-impact unauthenticated RCE with elevated attack complexity due to the narrow timing window (CWE-367, race condition / TOCTOU on predictable staging paths during WordPress's full-package core upgrade process). Confirmed in CISA's KEV catalog (added 2026-11-03, due 2026-11-06), overriding the low EPSS prediction — real-world exploitation is confirmed fact, not a probability estimate. No public exploit code has been published yet, and no vendor patch is currently available, making this an active zero-day situation requiring interim mitigations rather than patching.
This is a general assessment based on public vulnerability data. It does not account for your specific infrastructure — when in doubt, consult a security specialist.
Where each signal puts this CVE on the scale from published to confirmed exploited.
EPSS49th
CISA KEV
PublishedPublic exploitConfirmed exploited
CISA KEV
Listed as exploited in the wild since 2026-11-03.
US federal agencies must remediate by 2026-11-06.
Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
Public exploits
No public exploit or proof of concept found in the sources we track.
EPSS
0.6% chance of exploitation activity in the next 30 days, which ranks it in the 49th percentile of scored CVEs.
Exploit Prediction Scoring System, FIRST.org. A probability, not a confirmation.
Lifecycle
7 events over 3 days, from the signal feeds we watch.
Published2026-10-31
Added to CISA KEV2026-11-03
Added to CISA KEVrecord updated
Record updated
Publishedweakness classified, att&ck mapped, record updated