CVE Tools

CVE-2026-111497

Out-of-Bounds Write in Google Brotli Decoder

Exploitation likely. EPSS gives it a 33% chance of exploitation in the next 30 days. Fixed versions are out.

Published Updated Sources: CVE.org, NVD

What to do

Find your product and version, then upgrade to the build on the right.

  • Google BrotliAffected: ≥ 1.0.3, < 1.0.10Upgrade to: 1.0.10Affected: ≥ 1.1.0, < 1.1.1Upgrade to: 1.1.1Affected: ≥ 1.2.0, < 1.2.1Upgrade to: 1.2.1Stated by: CVE record

Versions as the sources state them. Full version matrix after sign-in

Steps

Written by AI from the record
  1. Ask your developer or IT provider whether any software you use (including Node.js) bundles Brotli version 1.0.3 through 1.2.0.
  2. If you run Node.js directly, update to the latest security release that includes the fixed Brotli version.
  3. For custom applications, update the Brotli library to 1.0.10, 1.1.1, or 1.2.1, whichever matches your current branch.
  4. Confirm with your vendor if you use third-party software that may embed Brotli, and ask them to confirm they've updated.

What it is

From the CVE record

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

In plain language

Written by AI from the record

A flaw in the Brotli compression library (used inside many apps, like Node.js) could let a malicious file crash or corrupt a program, but there's no sign anyone is exploiting it, so fix it on your normal update schedule rather than panicking.

Out-of-bounds write in Google Brotli's decoder (decode.c) triggered by a crafted Brotli-compressed stream, affecting versions 1.0.3–1.2.0 and allowing memory corruption, information disclosure, denial of service, or potentially remote code execution.

If you're affected

  • Application crashes
  • Possible data exposure
  • Potential remote code execution
  • Service disruption

Exploitation

Where each signal puts this CVE on the scale from published to confirmed exploited.

EPSS98th
CISA KEV

Not in the catalog. CISA has not confirmed exploitation.

Public exploits

No public exploit or proof of concept found in the sources we track.

EPSS

33% chance of exploitation activity in the next 30 days, which ranks it in the 98th percentile of scored CVEs.

Exploit Prediction Scoring System, FIRST.org. A probability, not a confirmation.

Lifecycle

18 events over 4 days, from the signal feeds we watch.

  1. Nuclei check addedpatch available, record updated
  2. EPSS band changelow → moderateepss band change
  3. Patch availablepatch available, record updated, record updated
  4. Patch availablepatch available, record updated, record updated
  5. Patch availablepublished, weakness classified, att&ck mapped, record updated

Affected products

Technical detail

Weaknesses

ATT&CK techniques

Mapped from the weaknesses above (CWE to ATT&CK), not observed in attacks.

Sources

Watch the software you run.

My Stack ranks new CVEs for your products by real-world exploitation, so the next serious one reaches you without reading every advisory.

We'll flag the next CVE, public exploit or patch for Brotli, not every advisory.