CVE Tools

CVE-2026-110193

Langflow OSS is affected by multiple vulnerabilities

No known exploitation. EPSS puts it in the 56th percentile. Fixed in 1.13.0.

Check it yourself

No ready-made check. Neither Nuclei nor OpenVAS has one for this CVE yet.

Request a scan

Published Updated Sources: CVE.org, NVD

What to do

Find your product and version, then upgrade to the build on the right.

  • IBM Langflow OSSAffected: ≥ 1.0.0, ≤ 1.12.8Upgrade to: after 1.12.8Stated by: CVE record
  • LangflowAffected: ≥ 1.0.0, < 1.13.0Upgrade to: 1.13.0Stated by: NVD

Versions as the sources state them. Full version matrix after sign-in

Steps

Written by AI from the record
  1. Check your Langflow OSS version — anything from 1.0.0 to 1.12.8 is affected.
  2. If you're on pip, run the upgrade command to move to 1.13.0 or later.
  3. If you run Langflow via Docker, pull and redeploy the updated image for 1.13.0 or later.
  4. Review who has accounts on your Langflow instance — any logged-in user could trigger this, so remove accounts you no longer need.
  5. Confirm the fix by checking the version shown in the app after upgrading.
pip install langflow --upgrade

What it is

From the CVE record

IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker with a low-privileged authenticated account to cause the Agentic Assistant to generate or submit component code using these unblocked patterns, resulting in arbitrary operating system command execution on the server.

In plain language

Written by AI from the record

If you run Langflow OSS (versions 1.0.0 through 1.12.8) for building AI workflows, a logged-in user could trick it into running commands on your server — you should upgrade to 1.13.0 soon, but there's no sign anyone is exploiting this yet.

Authenticated low-privilege users can abuse Langflow OSS's Agentic Assistant to generate component code that escapes intended sandboxing patterns, achieving arbitrary OS command execution on the host (CWE-94, code injection).

If you're affected

  • Full server takeover
  • Data exposure from AI pipelines
  • Lateral movement into internal network
  • Operational disruption

Exploitation

Where each signal puts this CVE on the scale from published to confirmed exploited.

EPSS56th
CISA KEV

Not in the catalog. CISA has not confirmed exploitation.

Public exploits

No public exploit or proof of concept found in the sources we track.

EPSS

0.8% chance of exploitation activity in the next 30 days, which ranks it in the 56th percentile of scored CVEs.

Exploit Prediction Scoring System, FIRST.org. A probability, not a confirmation.

Lifecycle

12 events over 1 day, from the signal feeds we watch.

  1. Patch availablepatch available, record updated, record updated
  2. Patch availablepatch available, patch available, published, weakness classified, att&ck mapped, record updated, record updated

Affected products

Technical detail

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Scored 8.8 by NVD.

How it is reached

  • Attack Vector NetworkExploitable remotely over the network without any special conditions
  • Attack Complexity LowNo special conditions — the attack can be reliably reproduced
  • Privileges Required LowRequires basic user-level privileges
  • User Interaction NoneNo user interaction needed — fully automated exploitation

Scope

  • Scope UnchangedImpact is limited to the vulnerable component itself

Impact if exploited

  • Confidentiality HighTotal information disclosure — all data in the component is compromised
  • Integrity HighTotal loss of integrity — attacker can modify any data in the component
  • Availability HighTotal denial of service — the component is completely unavailable

Weaknesses

ATT&CK techniques

Mapped from the weaknesses above (CWE to ATT&CK), not observed in attacks.

Sources

Watch the software you run.

My Stack ranks new CVEs for your products by real-world exploitation, so the next serious one reaches you without reading every advisory.

We'll flag the next CVE, public exploit or patch for Langflow OSS, not every advisory.