CVE-2026-110192
Langflow OSS is affected by multiple vulnerabilities
No known exploitation. EPSS puts it in the 16th percentile. Fixed in 1.13.0.
No public exploit knownFix1.13.0Upgrade to this build
No ready-made check. Neither Nuclei nor OpenVAS has one for this CVE yet.
What to do
Find your product and version, then upgrade to the build on the right.
- IBM Langflow OSSAffected: ≥ 1.0.0, ≤ 1.12.8Upgrade to: after 1.12.8Stated by: CVE record
- LangflowAffected: ≥ 1.0.0, < 1.13.0Upgrade to: 1.13.0Stated by: NVD
Versions as the sources state them. Full version matrix after sign-in
Steps
Written by AI from the record- Check whether you're running Langflow OSS version 1.0.0 through 1.12.8.
- If deployed via pip, run: pip install langflow --upgrade.
- If deployed via Docker, pull the updated image for version 1.13.0 or later.
- Confirm the upgrade by checking the running version matches 1.13.0 or newer.
- Review who has user accounts on your Langflow instance, since this issue requires a valid login to exploit.
pip install langflow --upgradeWhat it is
From the CVE record
IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote authenticated attacker to obtain sensitive information due to insufficiently protected credentials.
In plain language
Written by AI from the recordIf you run Langflow OSS for building AI workflows, a logged-in user could see credentials they shouldn't — update to version 1.13.0 when convenient, but there's no sign anyone is exploiting this.
CWE-522 (insufficiently protected credentials) in Langflow OSS versions 1.0.0–1.12.8 allows a remote authenticated, low-privilege user to retrieve sensitive credential data without impacting integrity or availability.
If you're affected
- Credential/secrets exposure
- Internal data leakage
- Insider-access abuse risk
Exploitation
Where each signal puts this CVE on the scale from published to confirmed exploited.
- CISA KEV
Not in the catalog. CISA has not confirmed exploitation.
- Public exploits
No public exploit or proof of concept found in the sources we track.
- EPSS
0.2% chance of exploitation activity in the next 30 days, which ranks it in the 16th percentile of scored CVEs.
Exploit Prediction Scoring System, FIRST.org. A probability, not a confirmation.
Lifecycle
10 events over 6 days, from the signal feeds we watch.
- Patch availablerecord updated
- Patch availablerecord updated
- Patch availablepatch available, published, weakness classified, att&ck mapped, record updated
Affected products
Technical detail
CVSS 3.1 vector
Open in the CVSS calculatorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Scored 6.5 by NVD.
How it is reached
- Attack Vector NetworkExploitable remotely over the network without any special conditions
- Attack Complexity LowNo special conditions — the attack can be reliably reproduced
- Privileges Required LowRequires basic user-level privileges
- User Interaction NoneNo user interaction needed — fully automated exploitation
Scope
- Scope UnchangedImpact is limited to the vulnerable component itself
Impact if exploited
- Confidentiality HighTotal information disclosure — all data in the component is compromised
- Integrity NoneNo integrity impact
- Availability NoneNo availability impact
Weaknesses
ATT&CK techniques
Mapped from the weaknesses above (CWE to ATT&CK), not observed in attacks.
Sources
References in the record
In the news
Watch the software you run.
My Stack ranks new CVEs for your products by real-world exploitation, so the next serious one reaches you without reading every advisory.
We'll flag the next CVE, public exploit or patch for Langflow OSS, not every advisory.
A free account adds
- The full version matrix and every affected product
- Exploit links, proofs of concept and Metasploit modules
- Email alerts for the products you watch
- The same data over REST API, MCP and CLI