CVE Tools

CVE-2006-5465

Exploitation likely. EPSS gives it a 10% chance of exploitation in the next 30 days. No fix published yet.

Published Updated Sources: CVE.org, NVD

What to do

No fixed build or workaround is published yet. Limit exposure and watch for a patch.

  • PhpAffected: ≤ 5.1.6Upgrade to: after 5.1.6Stated by: NVD

Versions as the sources state them. Full version matrix after sign-in

Steps

Written by AI from the record
  1. Ask whoever manages your website or server what PHP version is running.
  2. If it is older than PHP 5.2.0, treat this as urgent — that software is also missing roughly two decades of other security fixes.
  3. Upgrade to a currently supported, modern PHP version (PHP 8.x) rather than just the old 5.2.0 fix, since PHP 5.x itself has been unsupported for years.
  4. Have your developer or host test the site after upgrading, since very old PHP code sometimes needs small adjustments to run on modern PHP.
  5. If you cannot upgrade immediately, ask your host to restrict or firewall direct access to the affected server while you plan the update.

What it is

From the CVE record

Buffer overflow in PHP before 5.2.0 allows remote attackers to execute arbitrary code via crafted UTF-8 inputs to the (1) htmlentities or (2) htmlspecialchars functions.

In plain language

Written by AI from the record

This is a very old PHP bug (fixed long ago in PHP 5.2.0) that let attackers crash or take over websites using certain text-handling functions; if your software is anywhere near that old, update it, but most businesses today are already well past this version.

Buffer overflow in PHP's htmlentities/htmlspecialchars functions (pre-5.2.0) triggered by crafted UTF-8 input allows unauthenticated remote code execution with no user interaction required.

If you're affected

  • Full website takeover
  • Server-level compromise
  • Website defacement or downtime
  • Customer data exposure

Exploitation

Where each signal puts this CVE on the scale from published to confirmed exploited.

EPSS96th
CISA KEV

Not in the catalog. CISA has not confirmed exploitation.

Public exploits

No public exploit or proof of concept found in the sources we track.

EPSS

10% chance of exploitation activity in the next 30 days, which ranks it in the 96th percentile of scored CVEs.

Exploit Prediction Scoring System, FIRST.org. A probability, not a confirmation.

Lifecycle

7 events over 7272 days, from the signal feeds we watch.

  1. EPSS band changelow → moderateepss band change
  2. OpenVAS check added
  3. EPSS band changemoderate → low
  4. Record updated
  5. Publishedweakness classified

Affected products

And 1 more affected product. See all after sign-in

Scale

How widely the affected products are used. This is not a count of vulnerable hosts.

Estimate Public sources, each figure dated. How much of it is already patched is not known.

PHP

Web

Usage: unknown. No public source measures this product yet.

Version split: unknown. No public source for this product.

Technical detail

AV:N/AC:L/Au:N/C:P/I:P/A:P

Scored 7.5 by NVD.

How it is reached

  • Access Vector NetworkExploitable remotely over the network
  • Access Complexity LowNo special conditions required
  • Authentication NoneNo authentication required

Impact if exploited

  • Confidentiality PartialSome information is disclosed
  • Integrity PartialSome data can be modified
  • Availability PartialReduced performance or service disruption

Weaknesses

Sources

Watch the software you run.

My Stack ranks new CVEs for your products by real-world exploitation, so the next serious one reaches you without reading every advisory.

We'll flag the next CVE, public exploit or patch for Php, not every advisory.